[Lazarus] Namespace

Andrew Brunner andrew.t.brunner at gmail.com
Sun Jan 9 21:42:20 CET 2011


On Sun, Jan 9, 2011 at 2:25 PM, Marcos Douglas <md at delfire.net> wrote:
>
> And what about procedures/functions? This "problem" isn't just about classes...
>
> In C, all the indentifiers would be unique, but not in Pascal. We have
> units (namespace) so, why use prefixes like TxyzEdit? Why not use, for
> example,  xyz.TEdit ("xyz" would be the company, whatever) in all
> declarations? Wouldn't more readable? And will have less conflicts
> with others names of class too. Procedures and Functions, the same:
> xyz.foo() not xyzFoo() how the most developers like to do.

We're going to have to get someone to work-around the duplicate
identifiers problem too.  But as it turns out with my case above, I
ran into another problem.  Identically named enums types didn't
compile b/c they themselves were duplicated.  I revised my code to
employ nested consts instead of enums, this way I was able to group
and simulate enums.




More information about the Lazarus mailing list