[Lazarus] DateDif function needed

waldo kitty wkitty42 at windstream.net
Mon Nov 18 18:15:52 CET 2013


On 11/18/2013 11:46 AM, Hans-Peter Diettrich wrote:
> J├╝rgen Hestermann schrieb:
>
>> I still find "CalenderDiff" the best name for this function
>> because it clearly states that differences are calculated for calender
>> dates and not for an homogeneous stream of seconds/hours/days.
>
> This raises immediately the next question: which calendar?

:choke: :splutter: :lol: you are right, though... GregorianCalendarDiff then?? 
but wouldn't that also need corresponding name changes to such routines as 
DaysIn* and others? or an additional parameter indicating which calendar is to 
be used? ;) O:)

-- 
NOTE: No off-list assistance is given without prior approval.
       Please keep mailing list traffic on the list unless
       private contact is specifically requested and granted.




More information about the Lazarus mailing list