[lazarus] Unit search, why doesn't it stop?

Vincent Snijders vrs at dds.nl
Thu Apr 6 18:34:32 EDT 2000

> >Well, I just tried that. I move all the *.ppw and the *.ow files to the
> >freshly created lcl\units directory and removed them from the
> >just to be sure.
> >Then again with the new lcl/units path:
> >
>E:\pp\source\lazarus\components\mwedit>ppc386 -Fu../../../rtl/win32 -Fu../.
> >/../lcl/win32 -Fu../../../packages/gtk -Fu../../lcl/units -vt
> hmm... it makes no difference but the ../../../lcl/win32 dir shouldnt
> anymore.
Where the type came from, I don't know but originally this was a reference
to fcl/win32 ...

> Did you try -vut instead of -vt
>gives some more info

I did and found the reason for recompiling:
Recompiling STDCTRLS, checksum changed for FORMS.

I tried to find a reason for this, and took a closer look to the make
process of the lcl. When I do a make in the lcl directory ppc386 compiles
(makes) the units vclglobals, lmessages, spin, registry clipbrd and
messages. During this proces the forms unit is compiled four (4) times,
during the make of lmessages, spin, registry and message.pp. No wonder that
the stdctrls unit got out of date, if your dependent units change so rapidly

At the moment I don't know how to go on and solve this problem, I hope you
hav som good ideas.

Vincent Snijders.

More information about the Lazarus mailing list