[lazarus] Problem Compiling

Marco van de Voort marcov at stack.nl
Mon Dec 18 02:49:04 EST 2000

> I have been away for quite a while now. We bought a house and moved in and
> that has taken a lot of my time. Anyway, since I last did a CVS update,
> the FPC team has released V1 and it appears they are now working on 1.1.
> Now that I have done a CVS update, I cannot get the RTL to compile any
> more. I get the following error:

FPC team is working on both 1.0.x and 1.1

Stabilising 1.0, and further development in 1.1. (which is going to be 1.2

To cycle 1.1 you will need a recent 1.0 snapshot (there are snapshots for
both 1.1 and 1.0 atm, since 1.1 is sometimes unstable), and start the 1.1
CVS checkout with that.

> "make RELEASE=1" and still get the same error. I'm using the last version
> of the compiler that I compiled before V1 was released (from the August
> timeframe). Do I need to download a newer version of the compiler binary?

> Does anyone know why I am getting this error and what I need to do to
> correct it?

The name of the System unit is now always System. The need for having
multiple names was lifted, so we corrected it after 1.0

However since this name is hardcoded (e.g. in the startup assembler files),
we can't make it configurable, so we simply changed it going from 1.0 to 1.1

More information about the Lazarus mailing list