[lazarus] Command line in Win32 [was: CVS Changes]

Michael A. Hess mhess at miraclec.com
Wed Aug 15 08:59:18 EDT 2001

Peter Vreman wrote:
> > No clue ... commandline to long ?
> Correct. It is not possible to detect the platform of make.exe so you
> need to specify it by hand if you want to use the environment for
> passing the options.
> So you'll get:
> make USEENV=1 OPT=-Ca

OK this sort of worked. But again I ask what changed????

I have been building win32 nightly binary releases for months with the
same setup. Changes are made to makefile and now the whole thing goes
bust. I never had a commandline to long before so what changed?

Now I said the above worked sort of. While it now compiles it blows up
on the link with ...

Compiling lazarus.pp
Linking lazarus.exe
-: final link failed: Permission denied
lazarus.pp(121,1) Warning: Error while linking

What gives with this. Permission denied? What permissions?

> Or take the makew32.zip from the win32-1.0.6/separate/ dir from the
> fpc ftp and use the native win32 tools.

OK you lost me here. If I am not already using the native win32 tools
then what am I using?????

==== Programming my first best destiny! ====

Michael A. Hess      Miracle Concepts, Inc.
mhess at miraclec.com   http://www.miraclec.com

More information about the Lazarus mailing list