missing files (Solved ?)

Peter Vreman peter at freepascal.org
Wed Aug 22 05:16:31 EDT 2001

> When fpcmake (version 20010815) tries to write a Package.fpc file it wants 
> to check all platforms (it hasn't this behaviour when writing Makefiles, 
> which I used to check).
> When searching for Package.fpc it looks in the lib/fpc/1.0.5 dir and the 
> lib/fpc/1.0.5/units/[platform] dir. The tar.gz with the missing Package.fpc 
> files was extracted in the lib/fpc/1.0.5/units/linux dir, so when writing 
> the package file it wants also to have a rtl/Package.fpc in the go32v2 dir 
> (and all other platform dirs).
> That was where your missing rtl error was from.

Strange. Using the -T<target>[,target] should only build a Package.fpc for the specified
targets without requiring the other targets. The Makefiles should have -T$(OS_TARGET) in
the line where it calls fpcmake.

> Solution:
> * Remove all Package.fpc files from the lib/fpc/1.0.5/units/linux/* dirs
>    (in the dir: rm `find -name Package.fpc`)
> * Extract the missing packages tag.gz in the lib/fpc/1.0.5 dir.
> By trying to fix this problem I ran into a fpcmake bug (?)
> When there is a Package.fpc in both lib/fpc/1.0.5/[package] and 
> lib/fpc/1.0.5/units/[platform]/[package], fpcmake also reports an error of 
> a missing [package]. Somehow internally it returns both dirs as one.

That's indeed the bug. I need to add $(firstword ) to the routine to only return the first
found version.

More information about the Lazarus mailing list