[lazarus] Newbie Q : Can't find classes.pas...

Marc Weustink marc at dommelstein.net
Fri Jun 28 17:35:17 EDT 2002

At 22:28 28/06/2002 +0200, Mattias Gaertner wrote:

>The compiler messages are irritating.
>Of course there is no platform dependency in the synedit sources.
>But I know this output. I got it on a nfs filesystem. When you compile 
>with -va you find out more:
>First the lcl and then the gtk-interface is compiled. Everything seems to 
>be allright. But when compiling synedit the compiler loads the ppu file 
>and wants to recompile the interfaces.pp of the gtk-interface and hence it 
>searches for the depending gtk sources. But the synedit Makefile does not 
>contain any clue to the gtk .ppus and therefore the compiler fails with 
>the strange error message.
>Even more strange was the fact, that this error only happened if you 
>compile lazarus in one step via a script (or Makefile). Compiling it 
>manually always worked.
>I copied the files to a local disk and everything compiles fine. But the 
>error vanished some time ago. I can't say, if it was the update to a newer 
>1.0.7 or an update to the network.
>I know there is another person who had definitely a correct setup and got 
>the same error but on a local disk. It also disappeared after some 
>(un)successful searching.
>So, there is a compiler bug, but it appears only in very rare cases. 
>Spooky fpc.

Now you are speaking of this... Indeed, I've seen something similar like 
this. To me it looks like a race condition somewhere so that the .o file is 
older (!) that the .ppu file. I thought that it had something to do with 
the fact that it is a SMP system or that I use pipes for assembly files, so 
I didn't pay much attention to it (touching the files solves it). I recall 
something that on a NFS mount i've seen such tiny time differences as well. 
Maybe this is the source of the problems.


More information about the Lazarus mailing list