[lazarus] Compiling lazarus

hjamilis hjamilis at pymesoft.com.ar
Mon Nov 18 14:29:07 EST 2002


I am trying to have a working Lazarus on linux (Mandrake 8.0).

I downloaded fpc from the lazarus page, and the sources via CVS.

I tried Make on the lazarus directory and I get:

[root at linux Lazarus]# make all
make -C lcl all
make[1]: Cambiando a directorio `/desar/Lazarus/lcl'
/bin/rm -f units/allunits.ppu
/usr/bin/ppc386 -gl -Fuinterfaces/abstract -Fu. -Fu/usr/lib/fpc/1.0.7/units/linux/rtl -Fu/usr/lib/fpc/1.0.7/units/linux/paszlib -Fu/usr/lib/fpc/1.0.7/units/linux/inet -Fu/usr/lib/fpc/1.0.7/units/linux/fcl -Fu/usr/lib/fpc/1.0.7/units/linux/mysql -Fu/usr/lib/fpc/1.0.7/units/linux/ibase -Fiinclude -FUunits -Fl. -Fl/usr/X11R6/lib -di386 allunits.pp
Free Pascal Compiler version 1.0.7 [2002/09/21] for i386
Copyright (c) 1993-2002 by Florian Klaempfl
Target OS: Linux for i386
Compiling allunits.pp
Compiling interfacebase.pp
Compiling lclstrconsts.pas
Writing Resource String Table file: units/lclstrconsts.rst
Assembling lclstrconsts
lclstrconsts.pas(64) Error: Assembler as not found, switching to external assembling
lclstrconsts.pas(64) Fatal: There were 1 errors compiling module, stopping
Closing script ppas.sh
make[1]: *** [allunits.ppu] Error 1
make[1]: Saliendo directorio `/desar/Lazarus/lcl'
make: *** [lcl] Error 2

Whats wrong?

If I need to download something else, please let me know where to find it.

I tried also on Win32 without success.

Note: I have lazarus sources on a Fat32 drive, mounted on linux.



More information about the Lazarus mailing list