[lazarus] Exeception on loading Lazarus

Vincent Snijders vslist at zonnet.nl
Wed Sep 25 14:18:06 EDT 2002

> -----Oorspronkelijk bericht-----
> Van: Andrew Johnson [mailto:aj_genius at hotmail.com]
> Javier <javuchi77 at yahoo.es> wrote:
> >I mean, for example, having everything under /usr/src/lazarus,
> and trying
> >to load it from my home directory.
> >Elsewhere doing:
> >
> >cd /usr/src/lazarus
> >./lazarus
> >
> >does work. Some days ago it worked from ANY directory
> looks like your right.. the last update to cvs aka Vincent's
> Cross Compiling
> Patch looks to have caused this when his new TargetOS value isn't set. To
> fix, open compiler options and select linux and apply, and open "build
> lazarus options" and type linux in the TargetoS fields.. after
> doing these
> it works..
> This needs a real fix though, so if you read this Vincent, want
> try and fix
> it?
> Andrew
I have looked into it, but I can't reproduce this error, so I am not sure it
is caused by my patch. I removed the build tools setting from
~/.lazarus/miscellaneousoptions.xml and the compiler options setting from
the lpi-file but still no error.

The only way I could get an error is by removing both
~/.lazarus/environmentoptions.xml and ~/.lazarus.dci and starting up in a
different directory.

I don't know what to do.

I also have noticed that at times there are empty lines in the xml files. I
don't know when this ocures, but it might have something to do with it.


More information about the Lazarus mailing list