[lazarus] io-bmp.c fails on line 282?

Tony Maro tonym at nlisc.com
Wed Sep 25 16:34:31 EDT 2002

On Wed, 2002-09-25 at 14:38, Michael A. Hess wrote:
> That's another point. I do have pixbuf and everything required on my 
> machine, it is just an earlier version. (0.11) It is obviously OK as far 
> as Lazarus is concerned because I make nightly binaries with this machine.
> So I downloaded your source and rebuilt it on my machine.
> I still get the same error even though it should have been built against 
> the libraries I have on my machine. I'm not sure what is going on.

Does the app run, though?  The warnings at runtime I just figured out...
it throws those if you set any properties of a component that you
haven't set the parent for yet.  Setting parent first followed by width,
height, etc... cleans up the list of errors.

FYI: I've got another fresh install of Mandrake 8.2 with pretty standard
package installs - it runs my original compiled app just fine.  Just
finished testing it.

I've created a custom test build here just to see what happens.  Here's
what I did:

The problem appears to be related to the creation of the FrmAbout.  In
fact, it happens during the creation process of that form.  I was not
using an oncreate event, so it's not directly my code.  What I just did
was delete the empty TImage component that was on the form and I now
create the TImage at runtime in the onshow event (freeing in onclose)
for the FrmAbout.

Now, that wouldn't answer the question of why it doesn't crash on the
main form creation, because I've got two blank TImage's on it.

Anyway for any daring souls with free time, particularly those who have
already been unable to run my app:


This is JUST the executable without the graphics so you'll need the full
package already to use this.  Replace the exe from the the actual
release.  (I just realized since it's only one file I could have left
off the tar, eh? LOL)


More information about the Lazarus mailing list