[lazarus] compiling problems

Vincent Snijders vslist at zonnet.nl
Wed Nov 5 14:38:15 EST 2003

On Wed, 05 Nov 2003 12:19:53 -0500
Andrew Johnson <acjgenius at earthlink.net> wrote:

> After the latest batch of updates from everybody for 1.1/1.9 I am no
> longer capable of compiling current cvs lazarus with 1.0.10, I first
> get an error on mode_t not found in fileproc.inc, and after that I got
> a whole slew of other errors I didn't bother to write down.
I only had a problem with filectrl.inc not fileproc.inc.

I tcan be solved by changing line 461 of filectrl.inc to
  mode:{$IFDEF Ver1_0}word{$ELSE}mode_t{$ENDIF};

> Since I had been wanting to try 1.1 again anyway I installed a cvs
> snapshot, and found that I was unable to link lazarus, upon linking of
> ./lazarus I was given lot of unresolved symbols "LEX" when I tried a
> make clean all. however using my gtk2 script, a gtk2 lazarus built
> fine. So I tried running make again, and this time it linked properly.
> make clean all always fails. odd.
> Also I am unable to build lazarus from within lazarus with fpc1.9, it
> gives me a "unable to create pipe" error. 
> Andrew
I am able to build it, but running it gives this error. Therefore I
reported this bug on the fpc bug tracker, bug number 2761, with a small
sample program showing the bug. A few days ago it crashed on the error,
but now it is silently caught, but error still happens. So no compiling
from the IDE is possible.


More information about the Lazarus mailing list