[lazarus] Compiling lazarus

Marc Weustink marc at dommelstein.net
Tue Nov 18 19:41:20 EST 2003

At 11:59 18-11-2003, Raúl Moratalla wrote:
>I have 256M of memory and I tried to compile lazarus wit FPC 1.19 to see
>if this could solve the problem.
>Now, I've compiled Lazarus with FPC 1.0.11 these are the steps that I
>$ LANG=es
>$ lazarus
>Gdk-WARNING **: locale not supported by C library

thats true, LANG=es is to short. It needs a country. See "locale -a" for 
all possible


>I've tried to make a backtrace following the steps that the other day
>Marc explained me:
>gdb lazarus
>This is what gdb shows on screen:
>Starting program: /home/raul/Compilar/lazarus/lazarus
>Program received signal SIGSEGV, Segmentation fault.
>$082c433c in TDYNHASHARRAY__ADD (ITEM=$bf0f9024, this=$8553b74)
>     at dynhasharray.pp:481
>481     dynhasharray.pp: No such file or directory.
>         in dynhasharray.pp

Catch !! and fixed (and probably lots of other strange errors)

The default index (or key) generator of TDynHashArray could return negative 
indexes. I've fixed it and I've added some extra checks to make sure valid 
indexes are used.


More information about the Lazarus mailing list