[lazarus] Problems building LCL documentation

Mattias Gaertner nc-gaertnma at netcologne.de
Tue Sep 2 11:28:21 EDT 2003

On Sun, 31 Aug 2003 20:02:45 -0300
Karl Brandt <pascalive at bol.com.br> wrote:

> Using Slackware 9.0 (or Kurumin 2.01) + fpc 1.0.10.
> Problems i found:
> 1) had to change from bin/bash to bin/sh to make the scripts (update*.sh 
> and make_all_skell.sh) work


> 2) running update_html -> error: dirsel.xml not found so

I added the new files.

> 3) run make_all_skell at lcl dir -> will break in forms.pp and graph*.pp

fixed in fpc cvs. 
The $IF directive was not implemented in the fcl pascal parser. I added a
simple skip.

> 4) after creating dirsel.xml and runing updateHtml i got the following 
> error:
> Writing 7433 pages...

Now it creates 8636 pages.

> An unhandled exception occurred at 0x080518EA :
> EACCESSVIOLATION : Access violation
>    0x080518EA
>    0xBFFFF120
>    0x080BB4B0
> Should this be reported to sg at freepascal.org 


> or is it a script problem?

I don't think so.

> PS: tried to compile CVS version without sucess. Tried 
> http://fpdoc.freepascal.org for lastest source but link is broken

I suggest to use the fpc cvs. The parser is not part of fpdoc, but of the


More information about the Lazarus mailing list