[lazarus] File "/home/amead/interfacebase.pp" not found

Andrew Johnson acjgenius at earthlink.net
Fri Sep 26 13:33:06 EDT 2003

its looking in the home dir probably because you have managed to screw everything up with having multiple config files. Since Upgrading rpms or removing rpms afaik will remove or backup configs I can only guess, but either you have been forcing rpms to install instead of upgrading or removing first, or as you say the rpms are broken. I would check for what fpc rpm's you have installed and then just remove them all. make sure all fpc and ppc386 configs are gone from the search path(both home dir and /etc), and install over again with a fresh install of the lazarus fpc and fpcsrc rpm from sourceforge(NOT the .src.rpm unless you know what you are doing). Then get a fresh copy of lazarus source from cvs and try a simple make, then run from the current directory the resulting ./lazarus and try and run a simple program. If that still doesn't fix it then I am clueless, there is only so much you can do to screw it up if you follow the proper way of doing things.


-----Original Message-----
From: Alan Mead <cubrewer at yahoo.com>
Sent: Sep 26, 2003 11:31 AM
To: lazarus at miraclec.com
Subject: Re: [lazarus] File "/home/amead/interfacebase.pp" not found

--- Mattias Gaertner <nc-gaertnma at netcologne.de> wrote:
> On Thu, 25 Sep 2003 19:58:42 -0700 (PDT)
> Alan Mead <cubrewer at yahoo.com> wrote:
> > I'm still having trouble getting started with Lazarus 
> When
> > I try to run a project (by clicking the 'play' button) I get a
> dialog
> > saying "File "/home/amead/interfacebase.pp" not found".  
> > 
> > In the messages window, it says:
> > 
> > syslinux.pp(5,1) Hint:  Conditional I386 was set at startup in
> last
> > compilation of syslinux.pp
> > interfacebase.pp(6,13) Fatal: Can't find unit CLASSES
> > 
> > Here's my the output of 'ppc386 -vt foo':
> > 
> > [amead at alan amead]$ ppc386 -vt foo
> > Searching file ppc386.cfg... not found
> > Searching file /home/amead/.ppc386.cfg... not found
> > Searching file /etc/ppc386.cfg... not found
> > Searching file fpc.cfg... found
> You are still not using /etc/fpc.cfg, but fpc.cfg in the current
> directory.
> Why do you have so many config files? You are not really a
> beginner, are you
> ;)

I'm definitely a beginner at Lazarus.  I've used freepascal for a
while.  I'll delete the extra file when I get home.  I have two

(1) What does the error message about interfacebase.pp mean?  Why
would the file be in my home directory?

(2) I've always installed from RPM but maybe my rpm is broken or
something, I've had this "file or directory not found" errors on
other src packages.  Is there a short outline for how I would get the
sources (i.e., a tarball or use the installed src RPM) and make them
from scratch? 

Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

     To unsubscribe: mail lazarus-request at miraclec.com with
                "unsubscribe" as the Subject
   archives at http://www.lazarus.freepascal.org/mailarchives

More information about the Lazarus mailing list