[lazarus] Lazarus stalls if compiled with CVS FPC

Den Jean den.jean at pandora.be
Fri Jan 2 19:03:40 EST 2004


since a couple of days Lazarus stalls at startup if compiled
with CVS FPC (it does not stall if compiled with fpc-1.9.1-031129.i386.rpm)
(I use Lazarus on Mandrake 9.2)

gdb learned me that Lazarus stalls at 
line 2758 of definetemplates.pas (TheProcess.WaitOnExit;)

if I compile Lazarus with fpc-1.9.1-031129.i386.rpm it just runs fine

fpc CVS was compiled/installed this way:
cd cvs/fpc
make clean
make all
make install

fpc-1.9.1-031129 was installed this way:
urpme fpc-1.9.1-031129.i386
urpmi fpc-1.9.1-031129.i386.rpm

and debugging with gdb:
//new for me, so give me a break,
//long live integrated debugging since TP 3 :-)

set args --no-splash-screen
... did 'n' till ...
the line ADefTempl:=CreateFPCTemplate(EnvironmentOptions.CompilerFilename,'',

then step into ('s')
and 's' till line 2758, there it stops (TheProcess.WaitOnExit)

BTW 'l' (list) doesn't work there for some reason, 
in main.pp it still worked
could someone tell me what to say to gdb 
so gdb always knows the sourcefiles for debugging a typical lazarus cvs dir 

kind regards,

Den Jean


On Wednesday 31 December 2003 12:59 pm, Michael.VanCanneyt at wisa.be wrote:
> On Wed, 31 Dec 2003, Den Jean wrote:
> > Hi,
> >
> > Libc.ErrNo:
> >
> > thanks alot for the very quick response.
> > I see the change in the new fpc cvs.
> >
> > 1) But lazarus won't run anymore if compiled
> > with this fpc. It stalls at startup.
> > If however I compile it with
> > fpc-1.9.1-031129.i386.rpm, it works fine.
> Strange, the version of FPC should not matter in this ?
> > 2) I also tried compiling fpc with a
> > {$define LIBC_OLDERRNO} added at the top of
> > unit libc.
> > But then fpc does not compile :
> > ppc386 -XX -CX -Xs -OG2p3 -n
> > -Fu/other/storage/rpms/lazarus/cvs/fpc/rtl/linux
> > -Fl/usr/lib/gcc-lib/i586-mandrake-linux-gnu/3.3.1 -Fl/usr/X11R6/lib
> > -Fl/usr/lib/qt3/lib -di386 -dRELEASE libc.pp
> > errno.inc(4,16) Error: overloaded identifier "errno" isn't a function
> > libc.pp(255) Fatal: There were 1 errors compiling module, stopping
> Fixed, an omission on my part.
> Michael.
> _________________________________________________________________
>      To unsubscribe: mail lazarus-request at miraclec.com with
>                 "unsubscribe" as the Subject
>    archives at http://www.lazarus.freepascal.org/mailarchives

More information about the Lazarus mailing list