[Lazarus] Fatal [Error]: Can't find unit URIParser used by XMLRead

Peter Williams pewtas at gmail.com
Fri Jul 25 01:05:24 CEST 2008

Burkhard Carstens wrote:
> Am Mittwoch, 23. Juli 2008 10:35 schrieb Emmanouil Paissios:
>> Hi all,
>> I recently developed a program using lazarus and observed that the
>> same executable for windows, performs completely faulty computations
>> in a specific computer to which, unfortunately, I do not have much
>> access, since it is the laptop of my supervisor. The aforementioned
>> machine runs windows xp, yet in other windows xp and windows 2000
>> versions I've tried, the program worked fine, also under wine. The
>> project compiled for linux and mac behaved correctly.
>> The program only performs various calculations according to a given
>> input specified by the gui and plots several charts. No input files,
>> no output files and no environment variables are used.
>> I would appreciate any ideas of why something like this could
>> possibly occur.
> First thing that comes to mind is different locale setting, i.e. decimal 
> separator etc. E.g. assuming the gui inputs are some floating point 
> values entered in edit fields and later converted to float with 
> StrToFloat, the conversion will fail, if the edit contains "1.23" but 
> the systems decimal separator is set to "," (like e.g. on a german 
> system) and thus expects "1,23".

In that case can help to set


or viceversa
at main form create event
> regards
>  Burkhard
> _______________________________________________
> Lazarus mailing list
> Lazarus at lazarus.freepascal.org
> http://www.lazarus.freepascal.org/mailman/listinfo/lazarus

More information about the Lazarus mailing list