[Lazarus] Fedora 8 problem

ron schultz ronschultzster at gmail.com
Fri Mar 28 15:07:59 CET 2008

The svn went fine. The next step did not.
[root at localhost lib64]# cd lazarus
[root at localhost lazarus]# ls

components    COPYING.modifiedLGPL  docs      install      lcl
  Makefile.fpc  test
converter     debian                examples  languages    link.res
  packager      tools
COPYING       debugger              ide       lazarus
localize.bat  ppas.sh       units
COPYING.GPL   designer              ideintf   lazarus.app  localize.sh
COPYING.LGPL  doceditor             images    lazbuild     Makefile

Below is just the first part but continues for about 300 more lines.

[root at localhost lazarus]# export LCL_PLATFORM=gtk2; make clean all bigide
make: -iVSPTPSOTO: Command not found
make: -iSP: Command not found
make: -iTP: Command not found
make: -iSO: Command not found
make: -iTO: Command not found
make -C ide cleanide
make[1]: -iSP: Command not found
make[1]: Entering directory `/usr/lib64/lazarus/ide'
make[1]: -iTP: Command not found

Below is the end of the out put. I do not want to make things worse.
Should I run fpcmake and then try again?

make[1]: -iTO: Command not found
make[2]: Entering directory `/usr/lib64/lazarus/components/rtticontrols'
Makefile:171: *** The Makefile doesn't support target linux-, please
run fpcmake first.  Stop.
make[2]: Leaving directory `/usr/lib64/lazarus/components/rtticontrols'
make[1]: *** [bigidecomponents] Error 2
make[1]: Leaving directory `/usr/lib64/lazarus/components'
make: *** [bigidecomponents] Error 2

On Thu, Mar 27, 2008 at 7:01 PM, Mattias Gaertner
<nc-gaertnma at netcologne.de> wrote:
> On Thu, 27 Mar 2008 18:06:26 -0500
> "ron schultz" <ronschultzster at gmail.com> wrote:
>  >[...]
> > I added gd-devel-2.0.35-1.fc8.x86_64. That changed the error to "can
>  > not find -lgdk" I think that is what I did! But if I remove that
>  > package the error does not go back to
>  > /usr/bin/ld: skipping incompatible /usr/lib/libglib.so when searching
>  > for -lglib /usr/bin/ld: cannot find -lglib
>  >
>  > I have reinstalled gd-devel-2.0.35-1.fc8.x86_64.
>  > I then added gkk-pixbuf-devel- The error
>  > remains "can not find -lgdk".
>  > I then added gd-prog-2.0.35-1.fc8.x86_64. Same error.
>  > There are packages referring to glib and glib-devel and gtk+ that are
>  > not installed but they are i386 packages. I am assuming I do not need
>  > them.
>  Are you aware, that there two gtk versions? 1.2 and 2.
>  The 1.2 is more stable and therefore the default under lazarus.
>  I heard that FC8 no longer supports gtk1.2.
>  You can build the gtk2 lazarus:
>  Download lazarus from svn or tgz. For example:
>  http://wiki.lazarus.freepascal.org/Installing_Lazarus#Downloading_Lazarus_SVN
>  You should now have the lazarus sources.
>  Now build the gtk2 IDE:
>  cd lazarus
>  export LCL_PLATFORM=gtk2; make clean all bigide
>  Mattias
>  _______________________________________________
>  Lazarus mailing list
>  Lazarus at lazarus.freepascal.org
>  http://www.lazarus.freepascal.org/mailman/listinfo/lazarus

More information about the Lazarus mailing list