[Lazarus] Fedora 8 problem

ron schultz ronschultzster at gmail.com
Sun Mar 30 20:31:09 CEST 2008

I got it working. This is a copy of a new post I did. Hope this helps
someone else.

I had not been able to get Lazarus to compile with Fedora 8. Being a
Newbie to Linux I probably had done some things wrong. In the forums I
found an install of Lazarus for SUSE by Ignace
I decided to try essentially the same thing with Fedora 8.

The processor is an AMD Athlon BE 2400 so this would be an install for x86_64.

I had tried so much stuff that I wanted to start with a fresh install
of Fedora 8. During the install I made sure that I selected
Development Library, Development Tools, GNOME Software Development and
X Software Development.

After the Fedora 8 install and updates these were the relevant
packages and their status as seen in the Fedora 8 Package Manager.
Lazarus was the only package that would need to be downloaded.

fpc-2.2.0-10.fc8.x86_64                                 available
fpc-doc-2.2.0-10.fc8.x86_64                          available
fpc-src.2.2.0-10.fc8.x86_64                           available
gdk-pixbuf-1:0.22.0-35.fc8.x86_64               installed
gdk-pixbuf-devel-1:0.22.0-35.fc8.x86_64     installed
gtk+-devel-1:1.2.10-59.fc8.x86_64               available
gtk+-extra-2.1.1-6.fc8.x86_64                       available
gtk+-extra-devel-2.1.1-6.fc8.x86_64             available

In the Fedora 8 Package Manager I did these things in the following order.

Selected fpc, fpc-doc and fpc-src in Package Manager then Apply. Good result.

Selected gdk-pixbuf and gdk-picbuf-devel then Apply. Package Manager
asked for install disk and did some checks for glibc? and gtk? Good

Selected gtk+-devel, gtk+-extra and gtk+-extra-devel then Apply. Good result.

Downloaded Lazarus. I tried yum localinstall
lazarus-0.9.24-0.x86_64.rpm. Yum came back with missing dependency
lazarus =fpc-2.2.0 which was already installed. Do not understand. I
tried rpm with –nodeps. Rpm –Uvh –nodeps lazarus-0.9.24-0.x86_64.rpm.
That worked fine. As far as I can see Lazarus works as expected. Being
a Newbie to Linux I'm not sure why the problem with yum installing
Lazarus. I guess something like yum does not know about the
repositories at sourceforge.net when it checked for dependencies.

Now on to trying to get up to speed in Linux.

More information about the Lazarus mailing list