[Lazarus] jitform.pas won't compile

Dave Coventry dgcoventry at gmail.com
Fri Nov 21 15:35:31 CET 2008


I've changed
/usr/bin/ppcx64-> to point to-> /opt/fpc/compiler/ppcx64
but this didn't work.

However, using PP=/opt/fpc/compiler/ppcx64 did work.

How is this going to affect my own applications? When I compile my own
apps, which compiler will they be compiled under? and does it matter?

2008/11/21 Vincent Snijders <vsnijders at vodafonevast.nl>:
> Dave Coventry schreef:
>> This is what I did:
>> I ran 'svn checkout http://svn.freepascal.org/svn/fpc/trunk fpc'
>> which downloaded the fpc files into /opt/fpc
>> I changed directory to /opt/fpc and ran 'make all', which seemed to
>> compile okay. Then I ran 'make install' which I expected to overwrite
>> the fpc-2.2.2 version as the default implementation.
>> However, that version still appears to be invoked when I try to compile
>> Lazarus.
> make sure the symlink from fpc in /usr/bin points to the correct ppcXXX
> compiler
> Or
> Do make PP=/path/to/installed/ppcXXX
> for i386:
> make PP=/usr/lib/fpc/2.2.2/ppc386
> For more details, read the buildfaq (google for buildfaq.pdf)
> HTH,
> Vincent

More information about the Lazarus mailing list