[Lazarus] Problem with TFloatSpinEdit component

Paul Parkyn zl3app at paradise.net.nz
Sun Apr 12 10:43:53 CEST 2009

On Sun, 2009-04-12 at 09:19 +0200, Graeme Geldenhuys wrote:
> On Sun, Apr 12, 2009 at 1:45 AM, Paul Parkyn <zl3app at paradise.net.nz> wrote:
> > I have updated FPC to 2.2.2-8 and Lazarus to 0.9.26-4 using Ubuntu 9.04
> > Beta
> >
> > The problem is still the same. I can type the decimal numbers into the
> > component but as soon as the focus goes to another component the decimal
> > part of the number disappears.
> I just tried with 0.9.27 (r19310) and the GTK2 widgetset and
> everything works fine. What widgetset are you using and what character
> (based on your locale) is the decimal character? On my system the
> decimal character is a fullstop - in other locales it can be a comma.
> Regards,
>   - Graeme -
Yes I have been doing more testing and it works ok up to 5 decimal
places. I require 6 decimal places to correspond with the accuracy
required by another program. Unfortunately I had not tried at a lower
number of decimal places(silly me).

It looks like I will have to live with this resolution.

Thanks for your help, I am using GTK and a Fullstop.

Regards Paul

More information about the Lazarus mailing list