[Lazarus] "Figures" in code explorer

Alexander Klenin klenin at gmail.com
Sun Apr 19 17:03:30 CEST 2009

On Mon, Apr 20, 2009 at 01:28, Paul Ishenin <webpirat at mail.ru> wrote:
> Martin Friebe wrote:
>> Hm, while some of them probably are most likely to be used to find
>> possible issues, there is no need to see them as an "problem indicator"
>> only.
>> So point 1 is "correct" as they are a collecion of numbers "figures"
>> Still, maybe they would be better named as "statistics"? (maybe
>> "analytics" ?)
> I would call them "IDE Hints" or "Code Hints". But "Figures" are also ok
> for me.

My main point with the name is usability. The name should convey
at least something about the named object to an unprepared reader --
this is an important rule both in programming and interface design.
So yes, 'code hints', 'analytics' -- anything suggested in this thread
is better than 'figures'.
(Not 'statistics', however, which, by the way, would be another
interesting feature)

Alexander S. Klenin

More information about the Lazarus mailing list