[Lazarus] Editor font disturbed after upgrading to r19705

Martin Friebe lazarus at mfriebe.de
Thu Apr 30 12:56:00 CEST 2009

Bart wrote:
> Hi,
> I just upgraded my Lazarus from r18956 to r19705  on Win9x.
> When I started Lazarus the font in the code editor had become almost
> unreadable (too small, appr. 5 pt.)
> I tried to adjust the font in using the appropriate dialog, but I
> could not get it as it was before.
> I then copied the editoroptions.xml from what used to be my "stable"
> version and applied it to r19705, so I was sure they both used the
> same fonts.
> However the r19705 renders the chosen font very differently.
It looks to me like it uses a different font. certainly it looks like it 
believes the font was proportional (that is why you get the odd spacing, 
because SynEdit forces it into a grid).

The last font-related changes in synedit where in revision 185xx (so 
before your last good revision).

I haven't got  Win9x, so I can't test. On XP it looks fine.

Maybe you could put some debugln into Synedit.SizeOrFontChanged and see 
which font is really used? Otherwise I have no idea.


> The "editor r18956.png" show how the editor font used to be,
> the "editor r19705.png" shows how it is rendered now.
> Here's the editoroptions.xml that both Lazarus' use:
> <?xml version="1.0"?>
>   <EditorOptions Version="4">
>     <Display EditorFont="Courier New" EditorFontHeight="-13" ExtraLineSpacing="0
> " ShowLineNumbers="False" ShowOnlyLineNumbersMultiplesOf="1"/>
>     <Color>
>       <LangObjectPascal Version="4"/>
>     </Color>
>     <KeyMapping>
>       <default>
>         <Version Value="5"/>
>         <printselection Value="80,1,0,0,0,0,0,0"/>
>         <jcfcurrenteditorwindow Value="68,1,0,0,0,0,0,0"/>
>       </default>
>     </KeyMapping>
>     <CodeTools CodeTemplateFileName="H:\PROGRAMMAS\SVNLAZ\lazarus.dci"/>
>   </EditorOptions>
> The fontheight of -13 looks strange, but Lazarus puts this value in
> when I choose the font directly from the font-dialog.
> I've tried changing the font-size to diffrent values (10 to 18) but
> nothing comes even close to what it used to be.
> The font is either too big, or too small, or the kerning (the space
> between individual characters) is too large.
> B.t.w. Yesterday I upgraded my Lazarus on Linux (GTK2) to r19690 and I
> noticed no fonts changes at all.
> Is this a bug, or is there something wrong with my system?
> Bart
> ------------------------------------------------------------------------
> ------------------------------------------------------------------------
> ------------------------------------------------------------------------
> _______________________________________________
> Lazarus mailing list
> Lazarus at lazarus.freepascal.org
> http://www.lazarus.freepascal.org/mailman/listinfo/lazarus

More information about the Lazarus mailing list