[Lazarus] linker error when I try to compile library

Vincent Snijders vsnijders at vodafonevast.nl
Tue May 26 21:57:17 CEST 2009

Grizzly(Francis Smit) schreef:
> Vincent Snijders wrote:
>> Grizzly(Francis Smit) schreef:
>>> Yeah I get the following error message:
>>> unitcmdline.pas(15,24) Hint: Parameter "value" not used
>>> unitcmdline.pas(16,24) Hint: Parameter "index" not used
>>> unitcmdline.pas(16,41) Hint: Parameter "value" not used
>>> cmdline.lpr(10,1) Error: Can't call the linker, switching to external linking
>>> cmdline.lpr(10,1) Fatal: There were 1 errors compiling module, stopping
>>> I'm on Ubuntu linux 9.04 and I'm using the packages from the repositories
>>> I probably need to put a bug report in with them but first I need to
>>> know what is going on
>> This may be caused by a buggy version of the binutils, the linker ld is part of it.
>> You can find a fpc bug report about it in the fpc bug tracker.
>> Vincent
> OK I chased the bug down and it said that the bug was not present in
> version 2.2.3 of the compiler so I upgraded, to version 2.2.4 but this
> did not help still get the same error

The fpc bug report I was referring to is:
and http://bugs.freepascal.org/view.php?id=12832

The actual bug is in the binutils. See for example 

Please, check your binutils version.


More information about the Lazarus mailing list