[Lazarus] changing some FPC units

Alberto Manganaro alberto.manganaro at unimib.it
Wed Dec 1 09:25:06 CET 2010

Well, but I don't want to install a new version fo the package, I just 
want to modify something in the original code, recompile it and use the 
unit in Lazarus.

I tried again but I can't figure it out, so my question is: where does 
Lazarus take the compiled FPC libraries to be linked with my project? 
When I put the recompiled files in the correct place in the FPC units 
folder, it seems that when I compile my Lazarus project it takes the 
units without modification! Thanks


Il 30/11/2010 17.21, Joost van der Sluis ha scritto:
> On Tue, 2010-11-30 at 17:14 +0100, Alberto Manganaro wrote:
>> Hi,
>> I'm trying to make modification in some units that are part of the FPC
>> (the .o and .ppu are in the units folder). I took the source code, made
>> my modification, rebuilt the .o and .ppu with the make command, and put
>> the new files in the utils folder.
>> Now I'm trying to recall these units from Lazarus, but it seems like I
>> have made no modifications. I tried to rebuild Lazarus (even if I think
>> it's of no use in this case) but nothing changes. If I jump from the
>> name of the unit to its code, I can correctly see my modification (the
>> FPC source code folder is correclty set) but if I compile I got some
>> errors that make me think that no modification in the compiled code of
>> the units has been made.
>> Do I miss something? Thanks in advance!
> Make install?
> You could also use fppkg.
> Joost.

Alberto Manganaro

Milano Chemometrics and QSAR Research Group
Department of Environmental Sciences
University of Milano-Bicocca P.zza della Scienza, 1
20126 Milano - Italy


More information about the Lazarus mailing list