[Lazarus] Can't find unit contnrs used by Masks

Martin lazarus at mfriebe.de
Fri Dec 3 20:22:21 CET 2010

On 03/12/2010 13:09, Michael Schnell wrote:
> "Recompiling contnrs, checksum changed for System
>   masks.pas(29,22) Fatal: Can't find unit contnrs used by Masks"
> Since many weeks I get this error when trying to recompile the newest 
> svn version of Lazarus with the newest svn Version of FPC.
> I remember that I once had this problem and it was solved by using a 
> more recent FPC.
> Will this problem be solved with a later version of either Lazarus or 
> FPC or do I do something wrong ?

What do do, depends on how you got into the error.

Did you update FPC?
Did you install a 2nd newer version of fpc in parallel to the 1st fpc?
Do you have several fpc versions and copied the installation to a 
different path?

Same for Lazarus.
Did you install a new Lazarus snapshot, that contains a newer fpc version?
Did you install it to a new location, in parallel to the old one?

Some config file has the wrong settings now.

Check what fpc compiler lazarus is using.
Check which fpc.cfg file this compiler uses, if it is started from 
inside Lazarus, or from within the makefile if you use make. (start fpc 
with -va / lots of output / search for fpc.cfg)

Check that all -Fu and other paths in this fpc.cfg file point to 
directories that where installed with this version of fpc.
Note, that if you change your fpc.exe, you must also have a complete new 
set of ppu files for fpc (rtl)

Check all directories in Lazarus. All -Fu settings, if you use any in 
building the IDE.
If you are not sure, find your laz-config dir, back-up it,and empty it.
or "user and settings" on older windows

clean out all *.ppu and *.o files in your lazarus directory, and in the 
directory of any package you installed and use in this lazarus installation.

Recompile lazarus

If you use more than one installation in parallel be aware there are 
many pitfalls: step1 inform yourself about --primary-config-path

More information about the Lazarus mailing list