[Lazarus] Help with lazarus on Mac

Darius Blaszyk dhkblaszyk at zeelandnet.nl
Thu Dec 30 20:33:45 CET 2010

On Dec 30, 2010, at 6:58 PM, dmitry boyarintsev wrote:

> On Thu, Dec 30, 2010 at 8:13 AM, Darius Blaszyk
> <dhkblaszyk at zeelandnet.nl> wrote:
>> I'm trying to get Lazarus working on a mac mini. What I did is the following;
>> 1. installed xcode_3.2.5_and_ios_sdk_4.2_final.dmg
>> 2. installed fpc-2.4.2.intel-macosx.dmg
>> 3. got lazarus from SVN and did a make clean all
> you're missing the 4th step:
> 4. run lazarus bundle (rather than the executable). the command is:
> "open lazarus.app"
That does not work. The app still freezes. I tried from finder as I described earlier, but also from command as you described.

> the other option is to run lazarus executable from the bundle" cd
> lazarus.app/Contents/MacOS/" "./lazarus", instead of the executable
> outside of the bundle.
This does work! Thanks for that. However if I do a "restart" from the IDE lazarus hangs again. I guess that lazarus will only start the way you described above. Luckily rebuilding lazarus works fine but only using Carbon. When I tried with Cocoa there was a compiler error on the "objectivec1" compiler switch. Is this a known issue? Is Cocoa in a state so I can compile the IDE already in it?

> ----
> note: you can ignore warnings "ld: warning: unknown stabs type 0xC0 in
> ../units/i386-darwin/outputfilter.o"
Understood, but what does this mean? Just for my curiosity.

Regards, Darius

More information about the Lazarus mailing list