[Lazarus] Web Module not works on Linux

silvioprog silvioprog at gmail.com
Fri Nov 19 21:59:15 CET 2010


Hi guys,

Attached I send a project to reproduce the error. To reproduce the error,
adds in "cgitest.lpr" the directive:

{$DEFINE SOLVES_ERROR}

On Ubuntu-10.10 I receive this error:

-------
Internal Server Error

The server encountered an internal error or misconfiguration and was unable
to complete your request.

Please contact the server administrator, webmaster at localhost and inform them
of the time the error occurred, and anything you might have done that may
have caused the error.

More information about this error may be available in the server error log.
Apache/2.2.16 (Ubuntu) Server at localhost Port 80
-------

In Windows (7) works normally.

How can I fix this?

PS. I'll need to use the unit Interfaces.

*----*
*Lazarus 0.9.29 r28168 FPC 2.5.1 i386-win32-win32/win64*
*Lazarus 0.9.29 r27752 FPC 2.4.0 i386-linux-gtk 2 (beta)*

Thanks. ;)

-- 
Silvio Cl├ęcio,
*programmer* *ObjectPascal*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20101119/990af407/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: CGIError.zip
Type: application/zip
Size: 2590 bytes
Desc: not available
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20101119/990af407/attachment-0002.zip>


More information about the Lazarus mailing list