[Lazarus] RichMemo 1.0.0 is broken. "Error moving component" error when creating component at design time.

Peter E Williams foss.game.pascal.developer at iinet.net.au
Sat Sep 4 20:30:32 CEST 2010

Hi Dmitry,

On Sat, 2010-09-04 at 17:59 +0000, dmitry boyarintsev wrote: 
> On Sat, Sep 4, 2010 at 5:26 PM, Peter E Williams
> <foss.game.pascal.developer at iinet.net.au> wrote:
> > Okay... I tried that version and it did not even compile. I have made
> > all the changes necessary to make it compile and it is not much of an
> > improvement. I have made my version (not working) available here:
> >
> > https://sites.google.com/site/pewtas/lazarus_code
> >
> > as RichMemo.1.1.2.pew.zip (not sure of what version number the one I
> > worked on was) 406 KB.
> >
> > I will be interested if someone can make some changes to get it working.
> >
> > I hope that it is not too much work for someone. I am not very used to
> > creating components! :-)))
> What exactly doesn't work you?

The error is almost exactly as I described before.

> If I attempt to add a new RichMemo to a form (at design time) then I
> get
> an "Error moving component" error and the code for the RichMemo is NOT
> created inside the form's unit. Note that the RichMemo does appear on
> the form but it cannot be selected (except with the Object Inspector).
> Error moving component
> Error moving component RichMemo1:TRichMemo

The only different is that this time if I try to add a new RichMemo at
design time, this time it will generate the above error then NOT place
the component on the form. Before it placed the component on the form
but not the code in the unit.

> thanks,
> dmitry

Proudly developing Quality Cross Platform Open Source Games
Since 1970 with a Commodore PET 4016 with 16 KRAM
http://pews-freeware-games.org (<--- brand new)

More information about the Lazarus mailing list