[Lazarus] Where to set project search paths in lazarus?

Bo Berglund bo.berglund at gmail.com
Thu Sep 30 12:38:25 CEST 2010

2010/9/29 Juha Manninen (gmail) <juha.manninen62 at gmail.com>:
> On Thursday 30 September 2010 00:07:03 Bo Berglund wrote:
>> I installed Ubuntu 10.04-2 on Sunday and then I used the
>> Synaptic Package Manager to get Lazarus and the associated
>> FPC compiler.
>> Lazarus version:
>> FPC version: 2.4.0
> You already have FPC 2.4.0 so it is easy. Just make sure you also have
> Subversion installed, and then:
> $ svn co http://svn.freepascal.org/svn/lazarus/trunk lazarus
> $ cd lazarus
> $ make all
> $ ./lazarus &
>> But just now I have decided to put Lazarus also on my main
>> PC, which is Win XP-Pro SP3 so I went to the Lazarus download
>> and retrieved lazarus-, which is
>> running the setup in the background just now.
>> Looks like Lazarus is the same version by the FPC is older...
> Install FPC 2.4.x + its sources from SourceForge and then get Lazarus again
> from SVN, either using cmd line or TortoiseSVN.
>> I have no idea whatever of what to do in order to "get the
>> SVN trunk", could you explain this or direct me to some
>> HowTo on the web?
> Here:
> http://wiki.lazarus.freepascal.org/Getting_Lazarus
> http://wiki.lazarus.freepascal.org/Installing_Lazarus
> although the pages are not very good because they give an impression Lazarus
> installation is a big and difficult operation while it is not.
> FPC trunk version installation is little more complicated but you don't need
> to do that.
>> I have never used SubVersion, I work in two companies that
>> are exclusively CVS houses....
> If you can use CVS, you can use anything. :-)

I tried the instructions on how to use TortoiseSVN to get the Lazarus
files as described here:

But Tortoise just initializes and transfers about 6 kb of data and then
nothing more happens. After some time of nothing happening I try to
Cancel, but that does not work so I have to close the dialog completely
using the X button.
Then in order to try again I have to delete the Lazarus folder with its
hidden .svn subfolder and create a new one because Tortoise does
not allow checkout any longer.
Tried it three times now, always the same end: nothing is retrieved.

Is the TortoiseSVN description on the webpage erroneous?

I had to install Tortiose because all other downloads I could find were
for installing an SVN *server*, which I don't want to do. So the only client
I found was TortoiseSVN...

Bo B

More information about the Lazarus mailing list