[Lazarus] Can't find unit LCLProc

David Emerson dle3ab at angelbase.com
Sat Nov 5 18:50:04 CET 2011

On Sat 5 Nov 2011, Mattias Gaertner wrote:
> On Fri, 4 Nov 2011 22:22:53 -0700
> David Emerson <dle3ab at angelbase.com> wrote:
> > I have a unit (sarala_text.pas) which is part of a package (sarala_tools)
> > that uses the LCLProc unit.
> > My package file lists LCLBase as a requirement
> > I am able to compile the package from the package viewer
> > I can ctrl+click on the unit name LCLProc and it takes me there
> > I can ctrl+click on procedures defined in LCLProc and it takes me there
> > But when I try to compile my project which uses lists sarala_tools (and
> > LCLBase) as requirements, then Lazarus says it can't find unit LCLProc. Why?
> > I recompiled fpc, with make clean all
> > Then I recompiled lazarus, with make clean all
> What Lazarus version?

git-svn-id: http://svn.freepascal.org/svn/lazarus/trunk@32710 

> Have you tried Run / Clean up build files?

I tried that, and I can compile/run my project.

However, even when that is possible, I still cannot "Build File" -- then it 
gives me the error again. So maybe the problem is with "Build File".


More information about the Lazarus mailing list