[Lazarus] Can't find package

Mattias Gaertner nc-gaertnma at netcologne.de
Sat Oct 8 10:18:51 CEST 2011

On Sat, 08 Oct 2011 10:08:54 +0200
"Santiago A." <svaa at ciberpiula.net> wrote:

> Hello:
> I had installed in my ubuntu 9.10 Lazarus 0.9.28. I finally decided to
> upgrade it to 0.9.30.
> I removed 0.9.28 to start from scratch, downloaded the deb packages
> fpc-2.42 and lazarus-0.9.30 (in big tarballS). 
> After several issues with dependences, I managed to install it. Besides, I have removed the $home/.lazarus directory
> But now I try to add the package sqlite3laz from the IDE, when I rebuild
> it and I get "Can't find unit sqlite3laz". But sqlite3laz.pas is in 
> /usr/lib/lazarus/0.9.30/components/sqlite.
> I tried to compile the package from menu package/open loaded package, but I get "you don't have permission to write 
> on /usr/lib/lazarus directory" or similar. So I have run Lazarus as root and compiled and tried again, now it has 
> compiled the package and generated the following files:
> /usr/lib/azarus/components/sqlite/lib/i386-linux/gtk2/sqlite3laz.o
> /usr/lib/azarus/components/sqlite/lib/i386-linux/gtk2/sqlite3laz.compiled
> /usr/lib/azarus/components/sqlite/lib/i386-linux/gtk2/sqlitecomponenteditor.ppu
> /usr/lib/azarus/components/sqlite/lib/i386-linux/gtk2/sqlite3laz.ppu
> /usr/lib/azarus/components/sqlite/lib/i386-linux/gtk2/sqlitecomponenteditor.o
> But when I build lazarus, I get the same result: "Can't find unit sqlite3laz"
> any path or macro missing? Any Idea or clue about what's happening?

Maybe you have some old ppu files somewhere.
Compile with fpc flags -vut to find out.


More information about the Lazarus mailing list