[Lazarus] Build Lazarus + MINGW32

Marco van de Voort marcov at stack.nl
Sat Jun 2 00:38:39 CEST 2012

On Fri, Jun 01, 2012 at 05:50:49PM +0300, Juha Manninen wrote:
> I tried to "make all" for at my work Windows machine. I have git and
> MINGW32 unix shell environment installed.
> The build fails as shown below. The problematic line is clearly this:
>   sh: C:\Program: No such file or directory
> For some reason "sh" is started and it does not understand spaces in paths.
> The interesting thing is that I use normal Windows cmd, not the MINGW32
> shell.
> If I test in MINGW32 shell, it gives the same error.

> "$ which make" in MINGW32 shell says (correctly) :
>   /c/FPC/2.6.0/bin/i386-Win32/make

FPC make is mingw shell, which tries to execute "sh" is found.

See http://www.stack.nl/~marcov/buildfaq/#toc-Subsection-1.2.4

(though that is about mingw make calling cygwin sh.exe but same thing. 

> I remember seeing questions of this problem also before. How to solve it?

Don't put sh.exe in your path or in the dir with "make.exe" in it.

More information about the Lazarus mailing list