[Lazarus] Running on mipsel

Mark Morgan Lloyd markMLl.lazarus at telemetry.co.uk
Thu Oct 25 21:22:45 CEST 2012


Sven Barth wrote:
> On 25.10.2012 20:03, Bernd wrote:
>> 2012/10/25 Mark Morgan Lloyd <markMLl.lazarus at telemetry.co.uk>:
>>
>>> something else appeared to be messing up e.g. the IDE's ability to
>>> store/access ~/.lazarus configuration settings: because of this lazbuild
>>> wasn't able to build a trivial test project prepared on a different 
>>> system.
>>
>> You can put environmentoptions.xml pointing to valid lazarus directory
>> into /etc/lazarus/ (lazbuild only needs the lazarus directory,
>> otherwise the xml file can be completely empty) and lazbuild should be
>> able to build LCL applications without existing ~/.lazarus
> 
> Mark can try that, but it won't help much if the error is located in the 
> MIPS code generator ;) (and little bugs there can lead to big problems 
> when running as I've learned with m68k ^^)

I'm pretty sure there are underlying problems, it appears to have been 
bombing out part-way through setting up the content of ~/.lazarus which 
contains an incomplete set of files.

I think that some of the performance problem might be an emulation or a 
guest kernel issue: I can see one of the kernel processes throwing a 
regular exception and this is probably wasting a lot of time.

I'm dropping this one for the moment to get back to rebuilding a test 
system and trying to re-run the SPARC tests. Apart from that I've got to 
get back onto other things I'm trying to work on (programmer's block )-:

-- 
Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]




More information about the Lazarus mailing list