[Lazarus] building lazarus 1.0 with make OPT="-n" and fpc.cfg in different location

Seth Grover sethdgrover at gmail.com
Tue Sep 4 19:02:57 CEST 2012

Greetings. First off, congratulations on the 1.0 release. Lazarus is a
terrific IDE and a great development platform.

I've got a script that I use to build FPC/Lazarus from source and roll
it into my own custom package. During the build of Lazarus,
/etc/fpc.cfg doesn't exist yet. This isn't a problem for the most
part, because I used samplecfg to generate an fpc.cfg file in a
temporary location. Then, when building Lazarus, I do it like this:

make bigide PP=/path/to/wherever/ppcx64 OPT="-n @/path/to/tmp/fpc.cfg"

The -n tells it to not use the regular cfg paths, and what follows
tells it where to find the cfg file to use.

This works fine for most of the build: lazarus builds and links, as
does startlazarus and some of the other binaries. However, when it
gets to building the "lhelp" binary under chmhelp, I can see my OPTs
aren't being passed down, and it fails with an error that /etc/fpc.cfg
doesn't exist.

I've worked around it by symlinking /etc/fpc.cfg to my temporary file,
but it would be better if it worked correctly.



This email is fiction. Any resemblance to actual events
or persons living or dead is purely coincidental.

Seth Grover

More information about the Lazarus mailing list