[Lazarus] Error: Can not load PostgreSQL Client library "libpq.dll".

Reinier Olislagers reinierolislagers at gmail.com
Sat Sep 29 11:13:32 CEST 2012

On 29-9-2012 10:54, Eric Kom wrote:
> On 29/09/2012 10:33, Reinier Olislagers wrote:
>> On 29-9-2012 10:09, Eric Kom wrote:
>>> Good day,
>>> Please I got a problem with libpq.dll library file, want I tried to
>>> select the Connected property to True, I received the Error: Can not
>>> load PostgreSQL client library "libpq.dll". Ckeck you installation.
>>> The library has been installed and copied to the project file.
>> Have you copied all required dlls? I noticed some more dlls in such as
>> libintl-8.dll, libiconv-2.dll and libeay32.dll
> the files libintl-8.dll, libiconv-2.dll are in the mingw folder already.
> and I copied the  libeay32.dll file to the project folder.

I did say "such as"... not a PostgreSQL expert - there may be more
Presumably your mingw folder is in your path?? If you rely on dlls in
your path you could just as well copy all dlls to your windows\system32
directory... which would set up the dlls for any project.

Anyway, you could try running depends.exe on libpq.dll to see if all
dependencies have been met...
Just to confirm: with project file you mean the directory where your
project .lpi is located, right?

>> Are you using the right bitness (e.g. 32 bit dlls for 32 bit compiler
>> (not OS), 64 bit for 64 bit)?
> am running on debian amd64, I installed virtualbox where I ran lazarus
> on windows XP 32bit.
>> BTW, specifying Lazarus version (and bitness) can be helpful...
> the version is 1.1

Ok, thanks, so 32 bit drivers would be in order...

More information about the Lazarus mailing list