[Lazarus] Arm-linux PPU invalid versioin 126

Sam sam_herzog at yahoo.com
Mon May 6 21:06:54 CEST 2013

Sorry, but i have not much good news for you. I already tried the past 4 months to get the android example running.

To setup the tool chain correctly seems to be very tricky.

All these parts (lazarus,free pascal,ndk,customdrawn controls) are in permanent change. Which is for sure by good intenion. 

The problem is now the additional information in wiki,docs and newsgroups are often outdated or not clear enough.

My current situation:

A)I have put a bounty to get a lazarus installer with android free pascal cross compile included.

B)I got a little closer yesterday by a kind answer from sternas in the codetyphon newsgroup. I will wait for version 4.30 and donate some money to his project. (its the only way i can help at the moment since my sparetime has become very limited)


GREP <epergola at outlook.com> schrieb:

>I followed the instructions in	
>"Using the pre-compiled compiler in Windows"(steps 1-3).
>When I Clean + build the example project "androidlcltest.lpi"
>I get:
> PPU Loading D:\lazarus\fpc\2.6.2\units\arm-linux\rtl\system.ppu
>PPU Invalid Version 126
>fcllaz.pas(0,0) Fatal: Can not find system used by fcllaz,
>Moreover, if I run Test in Project Options, I get:
>My Lazarus installation is the latest I found on sourceforge
>Please, help.
>View this message in context: http://free-pascal-lazarus.989080.n3.nabble.com/Arm-linux-PPU-invalid-versioin-126-tp4031143.html
>Sent from the Free Pascal - Lazarus mailing list archive at Nabble.com.
>Lazarus mailing list
>Lazarus at lists.lazarus.freepascal.org

More information about the Lazarus mailing list