[Lazarus] Nothing seems to work for missing breakpoint

Sven Barth pascaldragon at googlemail.com
Thu Nov 21 21:56:48 CET 2013

On 21.11.2013 19:13, GREP wrote:
> The url you gave me do not have a solution. They state the problem,
> but there is no  solution.

Did you try adding the drive where your sources reside to the "other 
unit paths (IDE only)" option? By judging your below examples it should 
be "D:\".

> I downloaded 1.0.14 and re-installed Lazarus.
> I first compile with the -g linker option, it compliled but still no blue
> dots.
> Then I tried with -gw -godwarfsets (I put -dgodwarfsets in the Define
> window).
> This time the Project does not compile, it gives me a bunch of erros like
> this for all files
> in the project:
> pos.lpr(30) Error: Failed reading coff file, illegal reloctype $000F while
> reading d:\cf1\output\pos.o

It could be that Dwarf is not correctly supported for WinCE...

> I went back to the -g option and get the same errors.
> I have d:\cf1\output in the output directory window (-FU).
> Any Idea what this is? I have no ebug outpu, b/c it stops before getting
> there

Test the following:
- disable generation of debug info and completely rebuild project (maybe 
delete *.o and *.ppu manually if necessary)
- enable generation of debug info (stabs/default) again and completely 

At work a colleague and me recently had success at debugging a WinCE 
program on the emulator though I had thought that it might not work.


More information about the Lazarus mailing list