[Lazarus] IDE problems - FIXED

brian brian at meadows.pair.com
Thu Nov 28 13:31:40 CET 2013

On 11/28/2013 05:08 AM, Martin Frb wrote:
> On 28/11/2013 08:38, brian wrote:
>> On 11/26/2013 04:02 AM, Mark Morgan Lloyd wrote:
>>> Run diff (e.g. kdiff3) on the old and new configuration files. Report
>>> back.
>> Sorry for the delayed reply, now programming is just a hobby, my
>> wife has other ideas about how I should spend my time... :(
>> Anyway, everything is local, my desktop is XFCE.
>> Checking the old and new directories, these are the directory listings
>> Old setup (showing the problem)
> Problem is that your main window (ide bar) is maximized. I just
> tested, I get the same error under fedora with xfce
> - Start IDE
> - maximize main-ide-bar
> - restart
> To fix: un-maximize
> Also notable: The maximize IDE bar should be restrained in high, but
> it is not. Though that may be ok, since the WM may override the LCL
> decision.

I've just tried it myself, Martin, and I confirm your findings. Thank 
you for solving the problem. Now, of course, I just have to figure out 
*HOW* the IDE bar got maximised, because as I said in my original 
posting, it appeared totally spontaneous. The first indication I had 
was in the middle of a debugging session when suddenly everything but 
the source window disappeared. If there's any way of maximising the 
IDE bar with the F7 and F8 keys then it's news to me!


More information about the Lazarus mailing list