[Lazarus] source editor: block commands don't work in Trunk v1.3

Graeme Geldenhuys graeme at geldenhuys.co.uk
Tue Oct 1 11:34:41 CEST 2013


I'm using Lazarus 1.3 r42869 FPC 2.6.2 i386-win32-win32/win64 and tried
to do the same thing that is possible with EditPad Pro. "Duplicate text
as you type" [http://www.editpadpro.com/trickduplicate.html]. This is
actually a very handy productivity tip.

I tried this in Lazarus but it didn't work. I thought it was maybe the 2
stage keyboard shortcuts that are causing a problem. eg: Ctrl+K,B

So I updated my keyboard shortcuts and added secondary shortcuts
matching what EditPad Pro has. Ctrl+Shift+B for Begin Block,
Ctrl+Shift+E for End Block, and Ctrl+D for Duplicate Block. I made sure
I have no shortcut conflicts.

The editor commands I modified are:

  - set block begin
  - set block end
  - copy block

Still, the blocking commands don't seem to work in Lazarus IDE. So have
these blocking commands maybe been broken for some time and nobody noticed?

As a side note:
This is probably not important. In my Windows 2000 system, my default
keyboard layout is United-States Dvorak. But as far as I know, the
Dvorak layout has never caused such problems. After all, a shortcut is a
shortcut, no matter what keyboard layout you use to type that shortcut.


More information about the Lazarus mailing list