[Lazarus] Compile works, building DEB package fails

Petr Hlozek petr at ok2cqr.com
Wed Jan 15 10:30:58 CET 2014


I'm developing my app in Lazarus for Linux. Now using version 0.9.30
because it's part of Ubuntu 12.04 repositories.

I've created makefile for the project
(https://github.com/ok2cqr/cqrlog/blob/master/Makefile) and it has
been working for long time without any problem.
Unfortunately, recent version of Ubuntu and Debian unstable building
fails. What is interesting, it happens only when it's building debian
package. Ordinary make in project directory works.

This is what I get from pbuilder-dist:

gline2.pas(707,9) Note: Local variable "z" not used
gline2.pas(707,11) Note: Local variable "x" not used
800 179.416/188.992 Kb Used
900 179.852/188.992 Kb Used
gline2.pas(896,6) Note: Local variable "z" not used
Fatal: Can't find unit typ used by spe
ERROR: failed compiling of project /tmp/buildd/cqrlog-1.7.0/src/cqrlog.lpi
make[1]: *** [cqrlog] Error 2
make[1]: Leaving directory `/tmp/buildd/cqrlog-1.7.0'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
I: unmounting /var/cache/pbuilder/ccache filesystem
I: unmounting dev/pts filesystem

The gline.pas is here:

It works when I use make or compile project directly in Lazarus. Only
when I try to build package, compilation fails. I also tried to
install dependencies that are in control file and it worked :(. Debian
unstable has Lazarus 1.0.10 and fpc-2.6.2-7.

Could you help me please? I can't release new version of my app because of this.

Thanks a lot!



More information about the Lazarus mailing list