[Lazarus] [ANN] Lazarus Manager v0.8

Hans-Peter Diettrich DrDiettrich1 at aol.com
Fri Jan 10 13:40:17 CET 2014

Kjow schrieb:

> More detail and download link here:
> http://wiki.lazarus.freepascal.org/Lazarus_Manager
> PS Please, take it as an hobby... I know that it can be improved a lot 
> and there are surely mistakes/faults, so please tell me which issues you 
> will find and I'll try to fix in my free time :)

On Win8-64
First problem: the edit box for the root directory shows strange 
behaviour. Inserting characters *into* text can make the cursor jump to 
the end of the text.

I'm missing an button for executing the Pre-Installation. "Start 
Necessaries Download" doesn't react, the "FirstInstall" button is far away.

SVN is not found, even if TortoiseSVN\bin is in the path, and I don't 
remember SVM problems with fpcup.
- what exactly should be in the path?
- does it harm when another SVN is installed by the manager?
- Clicking "Cancel" makes the program unresponsive, Windows kills it.
- The same when clicking "OK". The last log entry is
[10:47:25]: Start "gdb.exe" download.

fpcup had other problems, couldn't make it work either.

Second try in WinXP-32 VM
SVN can be started in a console, seems to be installed already.
Downloads seem to succeed.
Error: Binutils directory is empty.
Maybe .lzma and .tar are not supported? --> installed 7zip and zlib.
Now a couple of consoles seem to checkout the repositories.
All done - what now?

Try close a console: "Windows cannot cannot close this program"

Try "Update", more consoles open *and* close (rapidly, empty?)!
These seem to be the "make" consoles?
Error: Failed to execute: 2.
Huh? config: Drive=2 ?

At least the log continues, starting make's
*and* finally states "Update completed" :-)

Ending the program - the consoles still are open. Kill them now brutally :-]

But where are the binaries? Looking at the log, the INSTALL_PREFIX 
directories do not exist :-(

Log doesn't mention any missing paths, only:
Temporary EnvironmentVariable ("PATH"):
Files\CollabNet\Subversion Client\

Fix the shortcut file (root changed!).
Error: problems with android NDK...
Of course no such directories exist, I didn't select Android support!?
Ignore --> program starts, with all targets checked! :-(
Uncheck except win32.
QuickBuild --> "not yet implemented"
Close, remove Android directories from config.ini - oops, bad idea?
Remove "all" from the shortcut.
Start again, consoles open and close quickly - still no target 
directories created.

fpctrunk source missing "compiler" directory!

Creating batch file for start with above directories appended.
No difference :-(
Add CD... and make... for testing

C:/LazMgr/fpc/Bootstrap/ppc386.exe -Fui386 -Fusystems 
rtl -Fii386 -FE. -FUi386/units/i386-win32  -di386 -dGDB -dBROWSERLOG 
-Fux86 pp.pas
PPU Loading C:\pp\units\i386-win32\rtl\system.ppu
PPU Invalid Version 100
Fatal: Can't find unit system used by pp
Fatal: Compilation aborted
make: *** [ppc386.exe] Error 1

Cleaning \pp\units...
"Invalid Version" disappears, rest same error :-(

What's wrong?


More information about the Lazarus mailing list