[Lazarus] Lazarus on Odroid U3

Anthony Tekatch anthony at unihedron.com
Fri Jul 4 21:49:51 CEST 2014

On Tue, 01 Jul 2014 09:08:05 +0200, Reinier Olislagers <reinierolislagers at gmail.com> wrote:

> On 01/07/2014 02:03, Anthony Tekatch wrote:
> > On Mon, 23 Jun 2014 08:28:57 +0200, Reinier Olislagers
> > <reinierolislagers at gmail.com> wrote:
> >> .... You could try installing that or perhaps compile using FPC
> >> trunk (manually or using a tool like fpcup [warning: fpcup author
> >> speaking ;)] see here
> >> http://wiki.lazarus.freepascal.org/Odroid#Installing_FPC.2FLazarus_using_fpcup
> > I now have an Odroid U3 and am trying the instructions from your link
> > with the following error in fpcup.log:
> <snip>
> >  [2014-07-01 09:20:58.097 Info] DownloadFromSVN: SVN gave error code 1
> > It seems fpcup cannot see the SVN repository. Is a simple fix?
> Yes, it seems it finds the svn command but has problems downloading.
> Try again would be my suggestion. You can also try the svn checkout
> command manually in the relevant directory to see if that works.

The missing svn (from incomplete directory) was due to the disk size
being too small, I just had to enlarge as per leaflet that came with
odroid U3. I did not try to run the svn command from the command line
before I tried "df -h" to see 100% usage on that drive.

Next, locale was screwed up, fcpup --verbose showed this:
  svn: warning: cannot set LC_CTYPE locale
  svn: warning: environment variable LANG is en_CA.UTF-8
  svn: warning: please check that your locale name is correct
I had to do this:
  sudo locale-gen en_US.UTF-8

Next, there were some errors regarding Lazarus build:
 fpcup: info: Lazarus: buildmodulecustom: make/lazbuild returned error code 2
 fpcup: info: Error running fpcup. Technical details: error executing sequence useride; line: 2, param: USERIDE
 fpcup: info: Error running fpcup. Technical details: error executing sequence Only; line: 5, param: useride
 FPCUp failed.
so I did a "fpcup --clean" then tried the standard command (from your link).

Lazarus is installed now. 


More information about the Lazarus mailing list