[Lazarus] Code completion problems with Graph units

Mattias Gaertner nc-gaertnma at netcologne.de
Wed Sep 10 11:18:43 CEST 2014

On Tue, 09 Sep 2014 22:17:38 +0200
Sven Barth <pascaldragon at googlemail.com> wrote:

> Hello together!
> I'm currently working on a project that uses the good old Graph units 
> (or PtcGraph to be more precise) and I have the problem that code 
> completion is erratic if (Ptc)Graph is in the uses-clause, because the 
> IDE can not find the graphh.inc include file which is at the top of all 
> Graph units. This include file is located in $fpc/packages/graph/src/inc 
> whereas the full Graph units are located in other directories of 
> $fpc/packages/graph/src/.
> I've also tried adding the path of the include directory to the "Other 
> source files" or the "Include directories" path. The IDE then either 
> complains that it still can not find the file or it complains that it 
> could not find the end of the file with the cursor still getting 
> positioned at the $include directive.
> Any ideas I could try? (besides commenting out the include directive :P)
> Lazarus version is 1.2.4 on i386-linux-gtk2

Under Linux 64bit I can use the 'graph' unit and find declaration finds 
Then FD on the {$i graphh.inc} gets me to

Works on 2.6.4 and 2.7.1.

It works with unit ptcgraph as well:

Have you tried Tools / Rescan FPC source directory?

Note: The FPC source directory has its own search paths. It does not use
the project's search paths.


More information about the Lazarus mailing list