[Lazarus] RC1 Debugger error

JuuS JuuS at mykolab.ch
Sat Feb 21 15:21:34 CET 2015

Hi, I found the problem and solution...strange...!

This is the problem where I opened up the published project as suggested
in the testing instructions, compiled, and then get an immediate
debugger error on running.

I restored the pristine published files and was able to immediately
reproduce the problem.

So I did file diffs, nothing looked horrible but I started taking out
lines in the published version that weren't in the running version(s).

Crazy! but the first thing I removed fixed the problem, so it wasn't a
long process.

The offending line in the clean published PROJ.lpi file is:

<Icon Value="0"/>

( path to this line is <CONFIG>, <ProjectOptions>, <General> , full text

Removing this line, and compiling and running function perfectly right
off the bat.

It seems strange that no one else had this problem? Or is no else
testing?  ;-)

Anyway, HTH you track it down.

Oh, BTW, I didn't try the solution where running Laz from command line
to output to a debug LOG file. If you remember, that removed the problem
on my system during my first round of debugging...So apparently
something in that process "fixed" the LPI file????

Here is the LPI section....

<?xml version="1.0" encoding="UTF-8"?>
    <Version Value="9"/>
      <SessionStorage Value="InProjectDir"/>
      <MainUnit Value="0"/>
      <Title Value="TwinPrime"/>
      <ResourceType Value="res"/>
      <UseXPManifest Value="True"/>
      <Icon Value="0"/>                 <=== This must go

On 02/19/2015 02:42 PM, Martin Frb wrote:
> On 19/02/2015 09:53, JuuS wrote:
>> Some new developments!
>> Need to go somewhere, but I tried using laz in normal mode (not command
>> line) and opened the debug output window. I did not compile, just F9 and
>> the program worked just fine.
>> I then opened the origProject, compiled, ran and it ran fine.
>> I then opened the publProject again (no laz shutdowns), compiled, ran
>> and it also ran fine.
>> So problem is no longer, as far as I can see, reproducible after simply
>> running laz from command line with debug log.
>> HTH!?
> Maybe there was an old file and the project was not fully rebuild. And
> maybe at some time something triggered this rebuild.
> If it happens again, backup the folder(s). Try the logfile again (can be
> sent directly to my mail, bypassing the list)
> You can install the package "IdeLazLogger". This add a "logging" entry
> in the tool menu. And you can set a logfile, and log options while the
> IDE is running. Then if it happens again, you can just start logging
> without restarting the IDE.
> Which gdb version do you have? (run gdb from terminal / or check the top
> of the logfile you created).
> Note that according to my tests gdb 7.8.0 / 7.8.1 are less stable than
> gdb 7.7.x
> So if your system easily allows to downgrade, then consider this.
>> Also, the log file is quite large, appending it here would be over the
>> list email size limit I think. How is that usually done then? Upload to
>> a web site and then simply provide a link?
> (g)zip / bugtracker
> -- 
> _______________________________________________
> Lazarus mailing list
> Lazarus at lists.lazarus.freepascal.org
> http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus

More information about the Lazarus mailing list