[Lazarus] Failed to build lazarus release 1.4.4 from svn

Bo Berglund bo.berglund at gmail.com
Sun Nov 8 21:59:28 CET 2015

On Sun, 08 Nov 2015 16:15:59 +0100, Bo Berglund
<bo.berglund at gmail.com> wrote:

>4) Then inside the 1.4.4 dir I issued:
>time make bigide
>The response when it quit was:
>/usr/bin/ld: warning: ./link.res contains output sections; did you
>forget -T?
>/usr/local/lib/fpc/2.6.4/units/arm-linux/rtl/cprt0.o: In function
>(.text+0x88): undefined reference to `_fini'
>/usr/local/lib/fpc/2.6.4/units/arm-linux/rtl/cprt0.o: In function
>(.text+0x90): undefined reference to `_init'
>svn2revisioninc.pas(768) Error: Error while linking
>svn2revisioninc.pas(768) Fatal: There were 1 errors compiling module,
>Fatal: Compilation aborted
>Makefile:2740: recipe for target 'svn2revisioninc' failed
>make[2]: *** [svn2revisioninc] Error 1
>make[2]: Leaving directory '/home/pi/lazarus/1.4.4/tools'
>Makefile:3155: recipe for target 'all' failed
>make[1]: *** [all] Error 2
>make[1]: Leaving directory '/home/pi/lazarus/1.4.4/tools'
>Makefile:3080: recipe for target 'lazbuild' failed
>make: *** [lazbuild] Error 2

I have tried many iterations now but all stop at the same place with
an error because it cannot find _fini and _init while linking
svn2revisioninc, whatever that is.

I even checked out the lazarus revision 1.4 and tried to make all,
same story after 2.5 minutes it gives up at the exact same location.

I try to use fpc 2.6.4 for ARM, for which I have repeated my

sudo su
tar xvf fpc-2.6.4.arm-linux.tar
cd fpc-2.6.4.arm-linux
./install.sh  (Reply /usr/local to the first question)

Is it not enough to have downloaded the fpc 2.6.4 version and
installed it using the shellscript? Is something else needed too?

I have googled the exact error and I found it in a few discussions on
installing Lazarus but these were all about compiling the trunk
versions of fpc and lazarus, which I am not doing. Both directed the
user to set the symlink for ppcarm to point to where the version 3.1.1
is built.
Is seed fpc 2.6.4 not enough to compile lazarus 1.4.x release?

I want to get the release versions working since I had problems with
the trunk versions....

Please HELP! I have spent probably 10 hours today on this with
multiple downloads, builds and apt-get updates all in vain. :(

Bo Berglund
Developer in Sweden

More information about the Lazarus mailing list