[Lazarus] Compiling lazarus on arm-linux

Koenraad Lelong lazarus2 at de-brouwerij.be
Wed Sep 30 14:56:54 CEST 2015


I'm trying to compile lazarus on an arm-linux system (odroid C1, but 
also on RPi model 2). It works until this :

make --assume-new=svn2revisioninc.pas svn2revisioninc
make[2]: Entering directory `/home/odroid/Downloads/source/tools'
Makefile:2332: warning: overriding commands for target `.'
Makefile:2330: warning: ignoring old commands for target `.'
/home/odroid/fpc-2.6.4/bin/ppcarm -gl  -Fu. 
-Fu../components/lazutils/lib/arm-linux -Fu../lcl/units/arm-linux 
-Fu../lcl/units/arm-linux/nogui -FE. -FU. 
-Fl/usr/lib/gcc/arm-linux-gnueabihf/4.9 -Flinclude 
-Fl/etc/ld.so.conf.d/*.conf -dFPC_ARMHF -darm svn2revisioninc.pas
Free Pascal Compiler version 2.6.4 [2014/03/21] for arm
Copyright (c) 1993-2014 by Florian Klaempfl and others
Target OS: Linux for ARMEL
Compiling svn2revisioninc.pas
Assembling svn2revisioninc
Linking ./svn2revisioninc
/usr/bin/ld.bfd.real: warning: ./link.res contains output sections; did 
you forget -T?
/home/odroid/fpc-2.6.4/lib/fpc/2.6.4/units/arm-linux/rtl/cprt0.o: In 
function `_haltproc_eabi':
(.text+0x88): undefined reference to `_fini'
/home/odroid/fpc-2.6.4/lib/fpc/2.6.4/units/arm-linux/rtl/cprt0.o: In 
function `_haltproc_eabi':
(.text+0x90): undefined reference to `_init'
svn2revisioninc.pas(791) Error: Error while linking
svn2revisioninc.pas(791) Fatal: There were 1 errors compiling module, 
Fatal: Compilation aborted
make[2]: *** [svn2revisioninc] Error 1
make[2]: Leaving directory `/home/odroid/Downloads/source/tools'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/odroid/Downloads/source/tools'
make: *** [lazbuild] Error 2

Firt I tried with the latest stable sources, than I tried with the 
latest svn-verion, both the same error.

What am I missing ?
First compiled with "make all bigide", the tried with "make all 
OPT=-dFPC_ARMHF", both have the same problem.

Thanks for any help,


More information about the Lazarus mailing list