[Lazarus] Build of Lazarus fails on Mac with STABS error (perhaps because of MacOSX 10.11??)

Michael Ring mail at michael-ring.org
Wed Sep 30 15:22:31 CEST 2015

Two or three weeks ago I switched my main computer to OSX 10.11, now I 
tried to re-compile Lazarus but compilation failed. I compile Lazarus 
quite regulary, so my guess is that this is perhaps related to OSX 10.11 
as this problem is new to me and I have not seen others talking about an 
error like this in the forum (besides a thread in may, but this seems at 
least partially unrelated as I was able to compile lazarus during the 
whole summer.

I was able to make the main compile work again by adding -gw explicitly 
to OPT:

make clean all CPU_TARGET=i386 LCL_PLATFORM=carbon OPT="-k'-framework' 
-k'ApplicationServices' -gw"

So far, so good but when I run lazbuild the build fails:

lazbuild --build-ide= --ws=carbon --cpu=i386 --compiler=/usr/local/bin/fpc

Free Pascal Compiler version 2.6.4 [2014/02/26] for i386
Copyright (c) 1993-2014 by Florian Klaempfl and others
(1002) Target OS: Darwin for i386
(3104) Compiling debuggerintf.pas
(3104) Compiling dbgintfbasetypes.pas
<stdin>:4:9: error: unsupported directive '.stabs'
<stdin>:5:9: error: unsupported directive '.stabs'
         .stabs "dbgintfbasetypes.pas",100,0,0,Lf1
<stdin>:44:9: error: unsupported directive '.stabs'
         .stabs ":t1=-32;",128,0,0,0

The problem seems to be that with lazbuild the Makefile defaults are 
taken, this means for some modules that they are compiled with only -g 
which means with Stabs debug info and this perhaps is not valid anymore 
on Mac.

grep "\-g" /usr/local/share/lazarus/components/debuggerintf/Makefile
override COMPILER_OPTIONS+=-MObjFPC -Scghi -O1 -g -gl -l -vw- -vh- 
-venibq -vm4046

Any ideas how to solve this?


More information about the Lazarus mailing list