[Lazarus] Can't add new form to Lazarus App

Bad Sector badsectoracula at gmail.com
Sat Oct 1 11:59:47 CEST 2016

brian via Lazarus wrote:
> On Fri, 30 Sep 2016 00:38:39 +0300, Maxim Ganetsky wrote:
>> 29.09.2016 22:26, Terry A. Haimann via Lazarus ?????:
>>> I created the form by clicking on NewForm and then I tried to rename it
>>> from the Object Inspector.  I am running Lazarus 1.2.4  This app has
>> Lazarus 1.2.4? Is it a joke?
> This is straying from the point, but anybody who has worked for a
> LARGE (probably governmental) bureaucracy is likely to be all too
> familiar with being forced to use out-of-date software. Performing
> 'unapproved' upgrades may well mean disciplinary proceedings. Yes,
> I've had to work under those conditions. :(
> I completely understand the logic for the Lazarus developers wanting
> to know whether a problem can be reproduced with the latest version.
> You just have to remember that some people aren't allowed to use that
> version, as much as they would like to do so.
> Brian.

Also Lazarus/LCL and Free Pascal APIs aren't exactly stable between 
releases as with every release of both Lazarus and Free Pascal you have 
things that change and/or break (the string API changes are a recent big 
one, but many other things change every release).

It shouldn't be surprising when people want to stick with some version 
for a long time to avoid gotchas. Also when making branched releases you 
may want to keep the version of the tools you used at that release time 
around in case you want to do fixes later on that branch.

More information about the Lazarus mailing list