[Lazarus] Error when building Lazarus 1.6.2 from sources on RPi3

Bo Berglund bo.berglund at gmail.com
Tue Jan 10 08:18:13 CET 2017

On Tue, 10 Jan 2017 13:52:05 +1300, Gordon Findlay via Lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>I've had that issue, with different units, under Linux several times. A
>make clean before make bigide has solved the problem.
Well, in my case there was nothing to clean out since the source tree
for lazarus had never been compiled. I ran make clean anyway but the
problem for make bigide remains.

I suspect that while compiling lazarus it needs access to fpc sources
as well and I don't know how to tell the system where they are. I have
run make sourceinstall in the fpc source tree and it has deposited the
sources inside ~/share, but where does one tell the system where it
can find the sources?

For example there is no fpc.cfg file anywhere on my system, should it
not have appeared when fpc was built?

Bo Berglund
Developer in Sweden

More information about the Lazarus mailing list