[Lazarus] register 3rd party help with the IDE

Graeme Geldenhuys mailinglists at geldenhuys.co.uk
Sat Nov 11 10:15:02 CET 2017


Years back I wrote a tiOPF class documentation help intergation package 
for Lazarus. It could use local help (on your hard drive) or online help 
for the tiOPF.lpk package. But then it worked perfectly.

The other day I tried it out again with Lazarus Trunk, but it doesn't 
work. I tried to use the online help registration as follows:

  // for Online help files
   RegisterFPDocHTMLHelpForPackage('tiOPF2 Help','tiOPF2 Help Database',

After I rebuild Lazarus IDE, the "tiOPF Help" appears in the help 
database list, but no URL appears in the BaseURL setting, and Pressing 
F1 on any code found in the tiOPF.lpk package doesn't work.

Any idea what I need to do to get the ide help integration working again?

The unit in question can be seen by following the URL below. By default 
it uses local help on the hard drive, but I locally modified it to use 
the Online help instead. But like I said, it doesn't seem to work any more.



fpGUI Toolkit - a cross-platform GUI toolkit using Free Pascal

My public PGP key:  http://tinyurl.com/graeme-pgp

More information about the Lazarus mailing list